Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have a SharePoint 2010 site that works correctly, and a subsite that does not. When I open the subsite in SharePoint Designer, the "Lists and Libraries" view says "There are no items to show in this view." even though there are both Lists and Libraries defined for the subsite.

If I visit the http://site/subsite/_vti_bin/ListData.svc page it returns an empty document. http://site/_vti_bin/ListData.svc returns a valid XML document.

I have Full Control permissions for the subsite, and the Lists and Libraries all show up if I view the "All Files" folder. I have installed the data services update.

Update: I have also checked the SharePoint Designer settings. All permissions are selected globally and for the site collection in question. The top level site in the collection is working correctly; Only the subsite has issues.

share|improve this question

6 Answers 6

It was probably a problem with one of your lists or list templates. If you have a broken list, then it'll kill the listdata.svc page. See here: http://www.thorntontechnical.com/tech/sharepoint/sharepoint-designer-2010-listlibrary-there-are-no-items-to-show-in-this-view-listdata-svc-woes

share|improve this answer
    
How can I find the broken list without trying to delete everything one by one and restoring them? –  BGM Aug 3 '13 at 0:54
up vote 2 down vote accepted

I ended up deleting the broken subsite and creating a new one. The new subsite works correctly.

share|improve this answer
    
Please tick this as the accepted answer, to show your question as closed. –  Stuart Pegg May 12 '11 at 21:43

Having the same problem, I found a way.

First, I knew a list was broken, based on symptoms reported from other answers in this post (You should also check out this post, as it is quite informative). For one, alirobe's mentioning that /_vti_bin/ListData.svc isn't accessible if a list is broken.

When I went to "All Site Content", every list given there did work.

I couldn't discover which list it was that was broken, so in SPD, I went to "All Files" in Sharepoint Designer - which worked, even though many of the other Site Objects in "Navigation" didn't display anything.

I went through every list in "All Files" and used "Preview in Browser" on every one of them. Finally, I came to one that didn't open! Instead, it said,

feature d57f48.... for list template '100' is not installed in this farm...

So I deleted that list and everything began working again just fine in SPD.

There is a list of features here, by the way.

share|improve this answer

Check the "SharePoint Designer Settings" at site collection and webapplication level

share|improve this answer
    
Thanks for the answer, but I did check the SharePoint Designer settings. All permissions are selected globally and for the site collection in question. The top level site in the collection is working correctly; Only the subsite has issues. –  Garrison May 7 '11 at 11:59

Garrisons solution is not a solution to the problem. The problem is caused by a broken list like in the site mentioned earlier. See here: http://www.thorntontechnical.com/tech/sharepoint/sharepoint-designer-2010-listlibrary-there-are-no-items-to-show-in-this-view-listdata-svc-woes

The solution is removing the list that is broken using powershell. That should make the lists reappear and _vti_bin/listdata.svc work again.

share|improve this answer
1  
Okay, but how do I find the broken list? Myself, I can't navigate to /_vti_bin/listdata.svc - it asks me over and over to authenticate and never lets me in, even though I'm farm admin. –  BGM Aug 3 '13 at 0:50

i was have the same problem and the solution is there is list is broken but unfortunately you can detect this list so following the steps

1- backup your site with power shell or stsadm command

2- try to delete list by list and after delete one test the SPD it will find the that broken

3- restore the site and delete just the broken list

4- don't be afraid when you delete lists take your backup first and the restore is very easy

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.