Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I must have upset SharePoint somehow as I can't use the Central Administration to deploy an installed solution. Everything I do returns the wonderful '[SecurityException: Access denied.]' error.

I'm a domain administrator and a member of the local Administrators group. In fact, I went thru every local group on this machine and added my user account. Still no luck.

I AM able to deploy the solution via the SharePoint Management Shell though.

Any idea on how to fix the CA?

share|improve this question
add comment

2 Answers

To deploy a solution you must make sure you are a Farm Administrator. This won't be set through AD. So go to Central Administration and ensure your user account is added as a Farm Administrator. You may need to use a Farm Administrator account (the one that was setup) to add your user as such.

share|improve this answer
    
According to 'Central Administration: Site Settings : People and Groups - Farm Administrators' there are 2 farm administrators: BUILTIN\Administrators and my account. That's probably why I can use the shell. –  Iunknown May 4 '11 at 15:28
add comment

When you launch your browser, you need to Run as Administrator.

share|improve this answer
    
All this time and pain and it was as simple as 'running the browser as an Administrator'. Thank you so much! –  Iunknown May 4 '11 at 15:38
1  
Creating a new web application and Managing Services are other Central Admin actions that require your running as Admin. Sometimes buttons will be greyed out. The best bet is to always run Central Admin as an administrator. –  Laurie May 4 '11 at 15:48
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.