Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I upgraded SharePoint to 2010 Enterprise from MOSS 2007. Now, whenever a normal user goes to one of the pages, they get prompted for authentication. If they keep hitting cancel, it will let them through until they click on something else. I do the same actions and don’t get prompted for authentication (I am domain admin, admin on server, farm administrator). Do you have any idea why this is? I’m thinking it’s something on the file system, like they need access to the templates on the server or something, but I can’t find anything concrete in a google search. Any other ideas?

UPDATE: I made my test account an admin on the SharePoint server, and there are no authentication prompts. Does 2010 lock something down that 2007 didn't? If so, what folder and what permissions do users need to it?

share|improve this question
    
Are you using NTLM authentication? –  Kit Menke May 4 '11 at 14:35
    
Yes. The SharePoint server is in the trusted sites, and it's set to "Automatic Logon with Current username and password". –  nbride May 4 '11 at 15:01
    
1. Did your host name (FQDN) change after the migration to 2010? 2. If it changed - all the users client machines have this new FQDN added as a trusted site in the Intranet Zone in their browsers? 3. Do they get prompted for all the pages or only when they try to download a file that requires a client program to open? –  Karthik Murugesan May 4 '11 at 15:44
    
@Karthik 1. No. I did an in-place upgrade, so it's the same server / 2. see 1. / 3. They get prompted just when going to a site or a page in the site. They are not opening any files. –  nbride May 4 '11 at 15:50
    
Hi I am facing the same problem. Did you solve? How? –  Tito Jun 11 at 15:01
add comment

4 Answers 4

up vote 1 down vote accepted

Login as a normal user and use Fiddler to identify the secured resource (image/js/css) being requested.

From there you can tell if it's an object in the Content DB or an object on the filesystem.

share|improve this answer
    
See my update above in my post. I made the test user an admin on the server, an there were no prompts. –  nbride May 4 '11 at 15:34
1  
If the problem is that users are not admins and they see the prompt, shouldn't you remove Admin access and see what happens? –  MichaelF May 4 '11 at 15:43
    
I took the user back out of the admin group on the server, and I get the prompts again. –  nbride May 4 '11 at 15:50
    
This is telling me (and others) that you have files somewhere that either don't have the correct permissions or are not checked in and approved as major versions. –  PirateEric May 4 '11 at 17:05
    
It seems to be just with this one site collection. I have tried two different sites in it, which both prompt for authentication. I also tried a site in a different site collection, and that worked. –  nbride May 4 '11 at 17:47
show 2 more comments

Do you have all your pages set to authenticate? Are you expecting Anonymous Access for your Web Application? If so check your settings in the Central Admin/Application Administration/Web Application, select the Web Application and then Anonymous Policy and see if its set or not.

I've seen prompts like that when the policy is not set right.

share|improve this answer
    
SharePoint for us in an internal intranet type of thing, so we don't have anonymous access enabled. It worked great with 2007 (passing credentials through correctly), but since the upgrade, they get prompted. It does allow them through if they keep clicking cancel. Even if they put in their credentials, it doesn't make the prompt go away. –  nbride May 4 '11 at 14:55
    
So you are using AD for authentication? If that is not making things go away you might be running into something that requires elevated privileges. Do you have custom code? –  MichaelF May 4 '11 at 15:42
    
No, we don't have any custom code. We are fairly new to SharePoint, so we only have a couple of sites. –  nbride May 4 '11 at 15:55
add comment

Worth checking the standard libraries, such as the Style Library and Master Page gallery to check that all permissions are set on those correctly, and any locations that images may be being served from.

share|improve this answer
    
What are the permissions supposed to be? –  nbride May 4 '11 at 14:51
    
Make sure that all authenticated and/or anon users have read access to those locations. –  PirateEric May 4 '11 at 17:04
add comment

You have to enable Anonymous Access for you site. And then publish all resources (pages, images, styles) to make them available for anonymous users. If smth isn't published i.e. user doesn't have appropriate permissions for that he will be promoted for the credentials

share|improve this answer
    
Since they are using NTLM authentication, I don't think they will want to do this. –  Kit Menke May 4 '11 at 15:05
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.