SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've created a publishing page, placed a custom web part on in and published it. When I try to navigate to it I see this text instead of the content:

Page Content field value. Lorem ipsum dolor sit amet, consectetur adipisicing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo consequat. Duis aute irure dolor in reprehenderit in voluptate velit esse cillum dolore eu fugiat nulla pariatur. Excepteur sint occaecat cupidatat non proident, sunt in culpa qui officia deserunt mollit anim id est laborum.

Searching the web I've found similar pages, for example:

One thing about the page is that it's getting a query parameter called id - could that be causing the error?

share|improve this question
up vote 13 down vote accepted

I would say yes, it's certainly the query string parameter you are using. Check out this post for more details

share|improve this answer
+1 for more information available on this link. – ashish.chotalia May 3 '11 at 7:20
lol that sure is weird behaviour. Nice find – Anders Rask May 3 '11 at 7:58
I'm fairly certain this is the issue - I've sent the system admin the updated solution even before writing the question, but though I'd ask anyway. I'll update soon. In my defense, I should state that it worked on my machine, but not on the test environment. – Kobi May 3 '11 at 8:15
Important update - Our system guy is sick, so you won't get those 15 points for now, but you've got your health! – Kobi May 3 '11 at 8:53

Can you please recheck with giving id=1?

While passing ID as query string it's going to cast ID in some numeric format, so it will cause issues.

It's loading contents from the SiteLibrary pages document library.

share|improve this answer

For the cases when you want to use your custom web part inside of a SharePoint 2013 page, I can suggest you the following workaround:

  • download web part page from SharePoint 2010
  • upload it in SharePoint 2013 using the explorer view
  • add your web part that uses the reserved url parameters

In my case this worked. Here is a blog post I have written:

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.