SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have customized my DispForm, about 2 years ago, using SPD on my WSS3 site. I recently made an update, and now the association to the list is gone. All I did was modify a web part to include another field. If I type in the URL to my DispForm it works, but going to set the form in SPD as my DispForm, it doesn't work, and it's getting quite frustrating. Anyway I can force the association back??


share|improve this question
Can you clarify wwhat you mean by setting the form in SPD as DispForm doesn't work? In SPD, can you open your list, select your custom DispForm, and click Set as Default in the ribbon? – Laurie Apr 29 '11 at 6:26
Laurie: No ribbon in WSS3. :-) M. – Marc D Anderson Apr 29 '11 at 13:18

Are you changing the Supporting Files for the list in the properties? Don't forget that you need to select the right Content Type (usually Item or Document).

share|improve this answer
To check the supporting files, right click on the list in SharePoint Designer -> Properties -> Supporting Files. Make sure the "Display item form" is set to your custom form. – Kit Menke Apr 29 '11 at 13:59
Yes, I am specifying the suport files for the correct content type. I Click OK, then when I go back in, they're blank again. I've tried reverting back to an old copy of the dispform, which definitely worked then, and that can't join either. – David Lozzi Apr 30 '11 at 4:19
The filenames are blank, or set to the defaults? In any case, you could set the supporting files programmatically, either using the Web Services or managed code. I've seen this happen before, but I can't tell you why. – Marc D Anderson May 1 '11 at 4:33
Thanks Marc, I'll try it out in code. – David Lozzi May 4 '11 at 16:45
I setup the code to change the URL to the DispForm, and it worked, the URL has been updated (I can see it in SPD and when reading the content type via code) BUT it still doesn't work. SP is showing the view url as wss/?ID=123 – David Lozzi May 12 '11 at 18:06
up vote 0 down vote accepted

There's now a KB article for the fix

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.