Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I've upgraded a SharePoint 2007 (12.0.0.6421) database to SharePoint 2010 (no SP's or anything yet) and I noticed that there is no edit button that brings up the ribbon to edit a page in the upgraded SharePoint 2010 site. If I create a new site and new collection I get the edit button. If I create a new site collection under the upgraded 2007 web application I get an edit button, but I cannot seem to figure out how to enable this functionality on the upgraded sites. I've been banging my head against this all day.

share|improve this question
    
Are you able to perform a visual upgrade to the affected site collections? –  websch01ar Apr 27 '11 at 20:11
    
Can you verify that it's not a permissions issue? Try navigating to the page in edit mode by appending to the url: your-site/Pages/YourPage.aspx?ControlMode=Edit&DisplayMode=Design –  Laurie Apr 27 '11 at 21:05
    
Yes, I'd already done the visual upgrade at this point. I've tried appending to the querystring as well, but still no joy. I do get the page in edit mode, but not the in-place editing, no "edit page" or "save & close" buttons appear above the ribbon either. Thanks for the suggestions though! –  Scott Newman Apr 28 '11 at 15:32
    
Sorry, also, I'm a farm admin on this server as well. Heck, everything is running under my account on this box (I'm just testing the upgrade right now). Thanks! –  Scott Newman Apr 28 '11 at 15:34
    
Just fyi, I got this figured. The pages were web part pages, not just regular pages. Apparently, the edit button does not show for web part pages. Who knew. Regardless, thanks for the help! –  Scott Newman Apr 29 '11 at 17:50

3 Answers 3

If it happens in SharePoint 2013, try an play with your browser compatibility mode.

share|improve this answer
    
Can you please add more details about how to do this? Your answer is not as helpful as it could be. –  Robert Lindgren Aug 20 at 9:52

The missing edit button might be due to many causes: 1. You haven't been doing Visual Upgrade (which actually replaces your master page with the v4.master) 2. Your master page is not 100% compatibile with SP2010, nor does it use the elements from v4.master (collaboration) or the example nightandday.master

To add the button in your page you could use the <SharePoint:PageStateActionButton id="PageStateActionButton" runat="server" Visible="false" /> (if you've seen already that would generate the button on the left side of the ribbon)!

share|improve this answer

I think that the problem here is that on some pages the ribbon is hidden by default. You need to make it visible by clicking on "Show Ribbon" on the "Site Actions" drop-down menu.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.