Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

Currently on my SharePoint 2010 install the My Sites section is roped off on a sub-domain (port 80) of the main site collection. Whenever anyone opens the main site it automatically detects their username through AD and logs them in without prompting them. If they try to enter the My Sites sub-domain they are prompted to enter their username and password.

How do I get the My Sites site collection to act like the main site collection in regards to user credentials?

share|improve this question
add comment

2 Answers

up vote 7 down vote accepted

Most likely it is because the browser is not detecting that the subsite is in the proper domain. in IE, this is accomplished by making sure that everything that is *.intranetdomain.com is in the "Local Intranet" zone, which is usually done via Policy. It can also be done manually by going to Tools-Options-Internet settings-Security-Local Intranet-Sites-Advanced

share|improve this answer
    
What steps can I take to change this with Central Administration? –  JonnyP Apr 26 '11 at 15:14
1  
That is not really a Central Administration issue as the passing or ignoring of credentials is a decision made by the browser itself. In Central Admin, all you can do is ensure that you are using Windows Authentication for the site, which you are apparently already doing. –  Dave Wise Apr 26 '11 at 15:20
1  
So do I have to use GP to set the browsers for every employee to work properly? –  JonnyP Apr 26 '11 at 15:31
    
That is what most companies do. Just make sure to use the wildcard (i.e. *.intranetdomain.com) so that you don't have to update the policy for every subsite. If you have a higher level domain structure, like subdomain.domain.company.com, then set the policy to put *.company.com in the Intranet Zone. Whichever makes the most sense for your organization. –  Dave Wise Apr 26 '11 at 15:35
1  
WRT Mapped drives: It depends on what your OS is. If you're running Windows Vista or Windows 7, see support.microsoft.com/kb/943280. Putting in the required registry info fixed the credential prompting for us. Windows XP users were never prompted for their credentials for mapped drives. –  Evan M. Apr 26 '11 at 17:41
show 2 more comments

The simplest way I would go for it is implementing Kerberos. That, combined with browser settings to enable "Intranet Token caching" should do it for you in a blink.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.