Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

We have a Sharepoint 2010 farm across 4 servers and added "modfied" as a Key Filter for metadata navigation. When I select to filter on a specific day I enter a date the filtered results are out by one day, I actually have to enter the next day in the filter to find the correct items I want. E.g. to filter items modifed on 20/07/2010 I need to enter 21/07/2010 to get the results I want.

For each item the "Modified" column is showing the correct timestamp for the date/time the file was modified, so why isn't it returing the correct timestamp when I try to use the Key Filter? However 2 observations.

  1. If there is more than a page of results, scrolling forward a page then back a page delivers the correct results.

  2. If you remove the column from key filters then open the menu for the Modified Column Heading you can filter correctly on the dates.

All Servers and Sites or set the same regional Settings.

Yours Hopefully

Ross

share|improve this question

1 Answer 1

What I have found is that if Sharepoint is set to (UTC) Greenwich Mean Time but the servers are set to (UTC) Coordinated Time instead of (UTC) Dublin, Edinburgh, Lisbon, London. Then the Key Filters displays the correct result. It is almost as though GMT + Our Daylight Saving Time is throwing it 2 hours out instead of 1. Cheers Ross

share|improve this answer
    
Please tick this as the accepted answer to show the question as resolved. –  Stuart Pegg May 22 '11 at 20:09

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.