Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

On one site (portal.blah.com), I can open up a Shared Documents folder using the Action -> Open with Windows Explorer option

However, I am unable to do this with my second Sharepoint site (team.blah.com). The menu option is there, but it does nothing.

On this same PC, I can perform this action using Windows XP Mode and IE within it on the second site (team.blah.com).

Any thoughts as to what I can do to troubleshoot?

I am running Windows 7 64 bit and using IE 32 bit.

I have two Sharepoint sides by two different hosting providers, both WSS 3.0. I am connecting using HTTP, not HTTPS. I have the WebClient service enabled

Update Since my one client has two different OS, I suspect this is a Win7 64 bit configuration or security issue.

The version of both Sharepiont sites is 12.0.0.6421

This problem was in IE 8 32 bit, I have since upgraded to IE 9 32 bit and the same problem occurs.

Due to another issue (Windows 7 SP 1 upgrade failure), I have a fresh install with IE9, and now noticed that when I open the explorer view, I get a message indicating: "This webpage wants to run the following add-on: 'Control name is not available' from 'Not Available'.

IE Active X

Further investigation indicates that this is a bug in Windows 7 64 bit with Sharepoint.

Update Using Fiddler, I was able to capture the HTTP request/responses for my working session (IE 8 on Windows XP, running as XP Mode/Virtual PC) and nonworking session (IE 9 on Windows 7 64 bit).

Working
Request:

PROPFIND /Suppliers HTTP/1.1
Depth: 0
translate: f
User-Agent: Microsoft-WebDAV-MiniRedir/5.1.2600
Host: blah.mysite.com
Content-Length: 0
Connection: Keep-Alive
Pragma: no-cache

Response:

HTTP/1.1 200 OK
Cache-Control: private,max-age=0
Allow: GET, POST, OPTIONS, HEAD, MKCOL, PUT, PROPFIND, PROPPATCH, DELETE, MOVE, COPY, GETLIB, LOCK, UNLOCK
Content-Length: 0
Accept-Ranges: none
Server: Microsoft-IIS/7.5
MS-Author-Via: MS-FP/4.0,DAV
MicrosoftOfficeWebServer: 5.0_Collab
X-MSDAVEXT: 1
DocumentManagementServer: Properties Schema;Source Control;Version History;
DAV: 1,2
Exires: Mon, 20 Jun 2011 21:05:42 GMT
Set-Cookie: WSS_KeepSessionAuthenticated=80; path=/
X-Powered-By: ASP.NET
MicrosoftSharePointTeamServices: 12.0.0.6421
Date: Tue, 05 Jul 2011 21:05:42 GMT

Non-Working

Request:

OPTIONS /Suppliers HTTP/1.1
User-Agent: Microsoft-WebDAV-MiniRedir/6.1.7601
translate: f
Connection: Keep-Alive
Host: blah.mysite.com

Response:

HTTP/1.1 401 Unauthorized
Server: Microsoft-IIS/7.5
WWW-Authenticate: Basic realm="blah.mysite.com"
X-Powered-By: ASP.NET
MicrosoftSharePointTeamServices: 12.0.0.6421
Date: Tue, 05 Jul 2011 21:10:54 GMT
Content-Length: 0
share|improve this question
    
Is the client using IE9? –  Karthik Murugesan Apr 23 '11 at 20:48
    
I updated the question, I just updated to IE9 from IE8 –  RussellW Apr 25 '11 at 2:15
    
You need to compare the same request in both working and non-working. In the examples you posted, you show the PROPFIND request from the working session, but then the OPTIONS request from the non-working session. –  Dave Wise Sep 22 '11 at 15:49
add comment

3 Answers

Check your browser add-ons. Do you have an add-on "DivX Plus Web Player HTML5" enabled? If so, disable it and try again. For me this was the solution after investigating for hours and checking all the solutions like WebClient service, BasicAuthKey in the registry, repairing office installation... without success. If you don't have this add-on, check also if there are other add-ons. Disable them and try again.

share|improve this answer
add comment

If those SharePoint sites are running on SharePoint 2007 try the following.

Make sure "Webclient" service is running on the client PC. Since your servers use FQDNs the following registry fix might be required.

  1. Click Start, type regedit in the Start Search box, and then press ENTER. Locate and then click the following registry subkey:
  2. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WebClient\Parameters
  3. On the Edit menu, point to New, and then click Multi-String Value.
  4. Type AuthForwardServerList, and then press ENTER.
  5. On the Edit menu, click Modify.
  6. In the Value data box, type the URL of the server that hosts the Web share, and then click OK.
  7. Note You can also type a list of URLs in the Value data box. (eg. team.blah.com)
  8. Exit Registry Editor.

Try opening the explorer view...

More reading on MSDN

share|improve this answer
    
Unfortunately this did not resolve the issue –  RussellW Sep 22 '11 at 3:03
add comment

First thing would be to make sure that the second provider has the "enable client integration" option enabled for the authentication provider used by your app in Central Administration.

Second thing would be to compare the actual version of WSS used on each provider. It is possible that the second provider is out of date.

Lastly, fire up Fiddler and open Explorer view on the first site. Make note of the specific calls made to the server when you clicked on Explorer View as well as the responses. Then repeat the same process on the second site. Compare the calls and their responses between the first and second session. You will probably see that the responses from the second server differ in some way and that may explain the problem.

share|improve this answer
    
Client integration is definitely turned on, since I can see the "Open in Explorer" in my WinXP running in XPMode on Windows 7. But I cannot see this option direclty on Windows 7. I updated the question with the version number of sharepoint, they are the same. –  RussellW Apr 22 '11 at 22:41
    
I second the recommendation to use Fiddler. I've found it helps a lot of http and web service issues. –  Tangurena Apr 24 '11 at 6:45
    
As you can see from my update, I have used Fiddler and have not determined any root cause just yet –  RussellW Sep 22 '11 at 2:53
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.