Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

On my All Site Content page, under Document Libraries, both the Site Assets and Style Library links point to the correct place: site/libraryname/Forms/AllItems.aspx

However, the Site Pages link just points to sitename/SitePages, which redirects to the home page. I can still get to the library by going Page > View All Pages from the homepage, or typing the address in manually, but I still want to fix the issue, and I've got no idea where I can change this.

Edit: As pointed out below, the link is fine, but the sitename/SitePages address is redirecting to the homepage rather than to the SitePAges library view. Any ideas how I can fix this?

share|improve this question
add comment

3 Answers

As far as I can tell, the behaviour for pages libraries is -

If you set one of the pages to be the "home page", it will navigate to that site if you hit the root url of the site.

If you hit the url of the site/name of pages library (e.g. sitename/SitePages) it will go to the page named "default" (maybe different name depending on type of library), regardless of any home page settings. If you change the name of the default page to something else it should go to AllItems.aspx.

I admit I haven't tried all the possibilities or all the different library and site templates. If anyone has done more tests or used Reflector it would be interesting to know more.

share|improve this answer
    
Just to note, on my two sites (one where Site Pages redirects to the Library page, one where it redirects to the home page), both have a page called Home.aspx marked as the site home page. –  Rawling Apr 21 '11 at 10:39
    
Interesting. I think marking as home page affects the logic when you navigate to the site, not the library. What happens if you rename the Home.aspx pages? –  SPDoctor Apr 21 '11 at 10:51
    
Hm, if I rename the page, then the site home page defaults to a blank page, and (on the problem site) the All Site Content > Site Pages link now leads to the library view! So, a workaround (rename the homepage, mark as home page again), although I still don't know why it's happening :) –  Rawling Apr 21 '11 at 10:59
    
very interesting notice! Thank you for sharing this. +1 –  Andrey Markeev Apr 21 '11 at 12:44
add comment

That link is correct sitename/SitePages. Sounds like the default page in the SitePages library is redirecting you to the homepage, either from a web part, javascript or permissions.

share|improve this answer
    
You're right, on my other site, the Site Pages link points to the same address but ends up in the Library, not with the home page. Any idea where this setting might be? –  Rawling Apr 21 '11 at 10:08
add comment

In the SitePages library, if you have a page stored with the name "default", it will automatically pull this page up instead of the library. Rename this file to something else, and the link to the site pages will work correctly again.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.