Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I am new to this type of development so I apologize in advance if this is a stupid question. But.....

I installed a web part that was packaged in a WSP through the Management Console as follows:

Add-SPSolution -LiteralPath c:\temp\mySolution.wsp

and

Install-SPSolution -Identity mySolution.wsp -WebApplication http://sp-dev:10000 -GACDeployment

If I go to System Settings->Manage Farm Solutions I see my solution installed there. I thought at this point I would be able to add this web part to pages but when I go to add it there is nothing in the Custom folder.

From the Central Admin I tried deploying it to my web application but it says it is already there. What do I need to do to make this web part available to my sites?

share|improve this question
1  
Just a small tip: You do not need "-LiteralPath" in the "Add-SPSolution" command. just the command the absolute URL of the .wsp file. I know it works with but small tips are fun and this seems the most appropriate place. :o) –  trgraglia May 12 '11 at 14:07

1 Answer 1

up vote 3 down vote accepted

This depends on how you set up your solution. You either need to activate the feature (to add the web part to the gallery if the feature does this), or you should be able to manually add it to the web part gallery. Go to the web part gallery (this will be in site collection settings -> Galleries). Here you see the available web parts. Choose the Documents tab and click on New Document in the ribbon. This takes you to a "New Web Parts" dialog page (which is probably not what you expected), where you should be able to see all the installed web parts. Check the boxes for the web parts you want to make available and then click on the Populate Gallery button.

share|improve this answer
    
Ok, so I went there but I don't see my web part. Just to be clear I was on http://sp-dev:10000, I went to Site Settings and under the Galleries header I went to "Web Parts". In there I did the new document thing. Are those the correct steps? –  Abe Miessler Apr 19 '11 at 23:43
1  
Actually I think I was looking in the wrong place. I went to the Site Collection Features link under the Site Collection Administration and was able to activate it from there. Thanks! –  Abe Miessler Apr 19 '11 at 23:47
    
Sounds like your solution package has a feature to add the web part, so you need to activate the feature - which you did. Great! –  SPDoctor Apr 20 '11 at 7:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.