Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I'm following this example - http://blog.henryong.com/2010/06/08/how-to-create-custom-sharepoint-2010-page-layouts-using-sharepoint-designer-2010/

I've gone to Master pages and layouts (_catalogs/masterpage/Forms/AllItems.aspx)

I've created a new page layout, when I hover over to click "Edit in Microsoft SharePoint Designer" the page opens in notepad

I've clicked on a few other aspx pages in this library and they open in Notepad.

But the master pages I clicked on do open in SP Designer.

Update with my answer
I did a Repair on SharePoint Designer and rebooted. Its working now.

share|improve this question
add comment

2 Answers

In IE go to Tools > Internet Options > Programs and see if "Microsoft SharePoint Designer" is selected as the "HTML Editor".

Also try going through Windows Explorer to Tools > Folder Options > File Types; select ASPX and set the "Opens With" to SharePoint Designer.

share|improve this answer
    
"HTML Editor" is Word, but I did a Repair on SharePoint Designer and rebooted. Its working now. –  gotsp Apr 19 '11 at 2:50
add comment
up vote 3 down vote accepted

I did a Repair on SharePoint Designer and rebooted. Its working now.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.