Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have a SharePoint Site Collection with regional settings changed to dd/mm/yyyy overall, all date picker controls change and I get the dd/mm/yyyy format.

I have an Enterprise Search Center in which we have the Advanced Search, where one can search for all content based on Created or Modified Date.

Now, this continues to only take mm/dd/yyyy format of dates inspite of that site's regional settings being changed to dd/mm as well.

How do we change this and make all the date parameters in the Advanced Search work on dd/mm/yyyy?

share|improve this question
add comment

2 Answers

I have/had a PSS case open regarding this. I'll need to check but I believe the problem is with FAST and it doesn't actually support different regions properly. You can see this if you navigate to the "Create User Context" from the site settings page.

If your region is en-US then the buttons have labels, if your region is en-GB then the buttons don't.

I'll come back later after I've searched my emails.

share|improve this answer
    
Confirmed. I have a PSS case open, and it was accepted as a bug by R&D. This problem is due to be resolved in FAST4SharePoint SP1. I don't have that signed in blood, but that's coming from a conversation I had with a PSS engineer. –  Neil Richards May 19 '11 at 10:22
add comment

Search Center is usually a site on its own you should be able to change the regional setting for the search center site.

share|improve this answer
    
I have done that Renzo, but no difference. Ofcourse within the results, the date that appears comes correctly in dd/mm format, but the Advanced Search Created / Modified properties based date format - takes only mm/dd –  Karthick S Apr 18 '11 at 13:08
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.