Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

Today i ran a powershell script that lists all the features on my Sharepoint 2013 system along with their 'scope' and 'GUID'. I noticed while looking at the list that it also includes features that were long ago un-installed.

One of these listed but un-installed features was part of a solution that installed a custom masterpage. After it didn't work i un-installed it. Then in VS i changed the scope from "web" to "site", rebuilt the package and tested on a 2nd clean test system where it worked perfectly. But when i try to install the solution on my original test system, it installs but my websites become unavailable until i un-install it.

The problem "i think" is that the feature in my new solution has a scope of "site" but Sharepoint still has a record of the feature in the system and lists it's scope as "web".

Now i could change the feature GUID of my new solution but i'd rather find out how to get rid of this old feature information that Sharepoint is hanging on to.

Does anyone know how i can delete or change this info within Sharepoint?

share|improve this question
    
Sounds to me that you have uninstalled solutions without doing a proper cleanup. Have you tested your content databases for missing references? Test-spcontentdatabase -Name Wss_content_DbName –  user19952 Aug 28 at 16:59

2 Answers 2

up vote 3 down vote accepted

I have faced the same situation many times. I used a tool called Feature Admin. It shows any features that are isolated and cannot be used including error occured. You can delete the unwanted or error occurred features through it.

share|improve this answer
    
Thank you. I will check that out asap. –  C. Poulain Aug 28 at 17:29
    
Great. It is a really useful tool and used by many people. For me, I always keep it in my dev environment. –  Malin De Silva Aug 28 at 17:31
    
Yeah it worked like a charm. Clicked on the "Find Faulty Feature in Farm" which found and fixed the problem. After that my installation was successful. Thanks again. –  C. Poulain Sep 2 at 14:34

There are two ways, one is powershell and other is 3rd party(codeplex) solution as Malin Mentioned.

How to remove Feature from site?

share|improve this answer
    
Thanks. Much appreciated. I will try those out and see how they work. –  C. Poulain Aug 28 at 17:30

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.