Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have several custom columns of type "Publishing HTML", and a page layout several controls which point to the columns:

<SharePointWebControls:RichTextField
    DisableInputFieldLabel="True"
    FieldName="WheelImage"
    runat="server">
</SharePointWebControls:RichTextField>

The problem is that in the end result, the page shows escaped HTML rather than the rendered output I would expect.

Oddly - when it edit mode - they render fine, showing the rendered output. But in the 'reader' view, it shows the raw HTML.

I have also checked the 'edit html source' in edit mode - and it looks fine, like HTML. But the browser source of the output page shows escaped html.

I found this describing the same problem, but its not a solution - as this happens on any browser.

Anyone any ideas?

share|improve this question
add comment

1 Answer

FYI to anyone, answered on MSDN:

When setting up this site - I had added the columns directly to the site, and not to the content type at the root of the site.

When I add tyhe colums to a custom content type - and then add that content type to the site (rather than the individual columns) - it works.

I have no idea why this would result in it rendering encoded HTML, but it seems to have that effect.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.