Sign up ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

Environment: SharePoint 2010 CU: December

In SharePoint page --> web parts the “Target Audiences” property not visible in web part tool pane.

I tried IISRESET, restart of the machine as well as mentioned in some MS forums, but it didn’t fix it.

Any help is much appreciated

share|improve this question
Which web part? – James Love Apr 13 '11 at 19:49
All the web parts – REVA Apr 13 '11 at 20:26
Are you on Foundation or Server? Can I verify you are looking for this property in the right place, in the Advanced section beneath the "Import Error Message" property? – Chris Beckett Apr 13 '11 at 21:09
Server ...Yes, we were looking at the right property. We have resolved it now, It was a user error :( check my comment below. Thanks – REVA Apr 13 '11 at 22:26

5 Answers 5

We had this problem because the App Pool associated with the User Profile service was not started. Starting it and refreshing the site corrected the issue.

Here's an MSDN forum with some other step-by-step solutions.

share|improve this answer

Looks like I found the solution for this problem. Was frustrated and got more confused with these misleading answers posted on the internet. Just follow these steps:

Central Admin -> Web Application General Settings -> Select your Web App (on which your site collection is hosted) -> Click on Service Connections from the top ribbon -> Check the User Profile Service Connection and save changes.

This should display the Target Audience property on your web part's Advanced property.

share|improve this answer

As Kishork noted, this particular issue was related to a custom audience filter. Just wanted to add that we've seen this same issue several times in our Sharepoint 2010 environment after using Metalogix to move content, or running various jobs. The initial symptom is the same - the target audience property isn't visible when editing a web part.

Running iisreset won't do the trick. I've seen several posts in various forums where admins have resorted to re-provisioning the User Profile Service application, which will work, but the solution in our environment has been pretty simple.

Just add a space, or any other small change, to web.config and save.

Not sure why this works, but try this if you ever run into this issue.

share|improve this answer
up vote 2 down vote accepted


By mistake we had a "-" char in the word "Culture" in web.config

Long version:

  • We were implementing custom audience Runtime Filter to enable targetting for Anonymous users and we replace the OOTB "Microsoft.Office.Server.Audience.AudienceManager" runtime filter with our custom audience Runtime Filter

  • When making the entry into the web.config for our audience runtime filter, by mistake the the below line had a "-" char in the word Culture (like "Cul-ture") (our Change control system added the char "-" for a new line break!)

    Assembly="MyLib, Version=, Culture=neutral, PublicKeyToken=8d532cf2904af4ae"
    BuilderURL="audience_chooser.aspx" />
share|improve this answer
@Shoban: You found a bug in the markdown editor, that's why it wasn't working as expected. Putting in something before the code seems to fix it:… – Alex Angas Apr 14 '11 at 6:51
@Alex Ah okay!! ;-) thanks – Shoban Apr 14 '11 at 6:57
Its not resolved for me i don't see Cul- in my web.config.... – user3494 May 24 '11 at 14:12

Under List Settings > Audience Settings, do you have audiencing enabled for that list?

share|improve this answer
His issue is with Target Audiences on Web Parts, not on lists. – Chris Beckett Apr 13 '11 at 21:07

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.