Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I migrated a 2007 site to 2010 and hit Visual Upgrade and now I get the error "One or More FieldTypes Are Not Installed Properly" when viewing some settings pages, content pages etc.

So, found a solution here and downloaded the tool here. But neither the 64 bit or 32 bit version works (it installs but when I click to run, windows says its not responding and the app shuts down) - running it on win7 64.

I thought I'd save a template of the Relationships List item from a clean 2010 site (including content etc) and then upload template to upgraded 2010 site, the idea being that I could create a list using the template (i would obviously rename the list afterwards).

But guess what...? The upgraded 2010 site does not load the templates when I click to Create a list. I just see the load animation indefinitely.

share|improve this question
1  
What error? did the error say "somebody kill me"? :) i think your error msg didnt make it to yournpost... Please add it –  Anders Rask Apr 12 '11 at 18:43
    
I know this is like shutting the stable door... but did you run stsadm -o PreUpgradeCheck prior to upgrading? What error message? As Anders says, please add the detail. –  Charles Lee Apr 12 '11 at 22:23
    
have you tried rolling back to the previous visual styles technet.microsoft.com/en-us/library/ff607998.aspx –  djeeg Apr 13 '11 at 0:57
    
The error is listed in the solution link I posted. "One or More FieldTypes Are Not Installed Properly" @Charles, I didn't do the upgrade, just the Visual Upgrade and the guy who did it is away. @djeeg No I have not, will take a look. –  Perplexed Apr 13 '11 at 13:32
1  
Problem fixed! 1. Go to the site collection feature administration under Site Settings. 2. Deactivate the SharePoint Server Publishing Infrastructure feature 3. Delete the Relationships list 4. Reactivate the feature. Now the name field name should be correct. –  Perplexed Apr 14 '11 at 14:34
show 2 more comments

3 Answers

Answer left in comment:

  1. Go to the site collection feature administration under Site Settings.
  2. Deactivate the SharePoint Server Publishing Infrastructure feature
  3. Delete the Relationships list
  4. Reactivate the feature.

Now the name field name should be correct.

share|improve this answer
add comment

I've always used SharePoint Manager (for 2007 and 2010) to figure out or fix weird SharePoint stuff like invalid fields, without having to code some solution or use Central Admin or Site Settings. It's worth a go at least. http://spm.codeplex.com/

share|improve this answer
add comment
up vote 0 down vote accepted

Oops, I think I was supposed to put the answer here instead of the comments above!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.