Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

On a SP2010-farm (1 Front-end) we have a webapp with one site collection.

In the sitecollection we have a library with some custom content-types for document sets. This library has worked OK for several months.

Now unexpectedly, when creating a new document set in the library I get an error

"Cannot find file".

I get this error with every document set I try to create, even if I try the default SharePoint document set.

In the ULS logs I find the error:

System.IO.FileNotFoundException: The system cannot find the file specified. (Exception from HRESULT: 0x80070002)
at Microsoft.SharePoint.Library.SPRequestInternalClass.GetMetadataForUrl(String bstrUrl, Int32 METADATAFLAGS, Guid& pgListId, Int32& plItemId, Int32& plType, Object& pvarFileOrFolder)
at Microsoft.SharePoint.Library.SPRequest.GetMetadataForUrl(String bstrUrl, Int32 METADATAFLAGS, Guid& pgListId, Int32& plItemId, Int32& plType, Object& pvarFileOrFolder)
at Microsoft.SharePoint.SPWeb.GetList(String strUrl)
at Microsoft.Office.DocumentManagement.Internal.EcmCommonUrls.GetList(SPWeb web, Id id)
at Microsoft.Office.RecordsManagement.RecordsRepository.EcmDocumentRoutingWeb.get_DropOffZone()
at Microsoft.Office.DocumentManagement.Pages.NewDocSet.OnInit(EventArgs e)
at System.Web.UI.Control.InitRecursive(Control namingContainer)
at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

I created (to test) a new library and added one of the custom content types. Then I tried to create a new documentset in this library, but I also recieved the error.

Any help is appreciated.

share|improve this question
    
if it is an option, try enabling customerrors in the web.config. this is usually related to a problematic reference to a file, which may be resolve by re-deploying and re-activating relevant features –  Tiago Duarte Aug 2 at 21:44
    
Thanks for your reply, I've enabled customerrors, but this doesn't give any other error or specification of the error. Do you mean 're-deploying' should happen on a feature like the 'documentsets'? There are no custom features enabled on this webapp. –  Rinze Smit Aug 13 at 6:49
    
if you dont have custom features then my only suggetion is custom errors. they usually show the exact exception rather than just file missing. there are a few webconfigs you may need to edit in order to see the exception. there is one in iis, and two in the hive: templates, admin and templates, layouts –  Tiago Duarte Aug 13 at 18:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.