Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

One of the servers where I am installing SP2010 continues to fail when running the Prerequisite Installer.
It seems not to like the Filter Pack 2.0. I even attempted to download and install it separately but it fails with a detailed message "The installation of this package failed" and nothing shows up in the event log.

• Application Server Role, Web Server (IIS) Role: configured successfully
• Microsoft SQL Server 2008 Native Client: installed successfully
• Hotfix for Microsoft Windows (KB976462): installed successfully
• Windows Identity Foundation (KB974405): installed successfully
• Microsoft Sync Framework Runtime v1.0 (x64): installed successfully
• Microsoft Chart Controls for Microsoft .NET Framework 3.5: installed successfully
• Microsoft Filter Pack 2.0: installation error
• Microsoft SQL Server 2008 Analysis Services ADOMD.NET: Installation skipped
• Microsoft Server Speech Platform Runtime (x64): Installation skipped (optional component)
• Microsoft Server Speech Recognition Language - TELE(en-US): Installation skipped (optional component)
• SQL 2008 R2 Reporting Services SharePoint 2010 Add-in: Installation skipped (optional component)

Here is a snippet from the PrerequisiteInstaller Log:

2011-04-11 16:48:26 - Installing Microsoft Filter Pack 2.0
2011-04-11 16:48:26 - "C:\Windows\system32\msiexec.exe" /i "E:\PrerequisiteInstallerFiles\FilterPack\FilterPack.msi" /quiet /norestart REINSTALLMODE=vomus
2011-04-11 16:48:27 - Install process returned (0X654=1620)
2011-04-11 16:48:27 - [In HRESULT format] (0X80070654=-2147023276)
2011-04-11 16:48:27 - Last return code (0X654=1620)
2011-04-11 16:48:27 - Error: The tool was unable to install Microsoft Filter Pack 2.0.
2011-04-11 16:48:27 - Last return code (0X654=1620)
2011-04-11 16:48:27 - Options for further diagnostics: 1. Look up the return code value 2. Download the prerequisite manually and verify size downloaded by the prerequisite installer. 3. Install the prerequisite manually from the given location without any command line options.
2011-04-11 16:48:27 - Cannot retry
share|improve this question

2 Answers 2

Clear your temp files, and then re-download the 64-bit version of the filter pack from here: http://www.microsoft.com/downloads/en/details.aspx?FamilyID=5CD4DCD7-D3E6-4970-875E-ABA93459FBEE

Save it locally to your server, shift right-click the FilterPack64bit.exe and copy as path. Click Start --> Run, type CMD, right-click the command prompt and run as administrator.

Right-click to paste the path to FilterPack64bit.exe, and then add /log:c:\log.txt.

The command prompt should look something like:

C:\Users\Administrator>"C:\Users\Administrator\Desktop\FilterPack64bit.exe" /log
:c:\log.txt

Hit enter, wait for it to fail, and then go look at the log, which will have verbose information as to why it is failing.

share|improve this answer
    
The filter pack bits is inside prerequisiteinstaller folder on SharePoint 2010 server image. You don't need to download it. –  user5295 Oct 19 '11 at 8:43
    
Thanks for providing that link! The TechNet forum post about this issue only provided a link to the Filter Pack 1.0... Had a heck of a time figuring out the correct URL. –  Shrout1 Nov 18 '13 at 14:57

I my case the problem was with Trend Micro Realtime Scanner preventing installation. Stopping the service allowed the install to complete.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.