Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

A workflow completes its tasks, but is still shown as running. When looking at the Workflow history the last entry is:

An error has occurred in Workflow Name.

The SharePoint log has the following error at that time:

Area: SharePoint Foundation
Category: Workflow Infrastructure
Level: Unexpected
Message:
Load Workflow Assembly: System.IO.FileNotFoundException:
Could not load file or assembly 'BihConsumerInterop, Version=14.0.0.0, Culture=neutral, PublicKeyToken=48e046c834625a88'
or one of its dependencies.
The system cannot find the file specified.
File name: 'BihConsumerInterop, Version=14.0.0.0, Culture=neutral, PublicKeyToken=48e046c834625a88'
share|improve this question
add comment

3 Answers

up vote 1 down vote accepted

This post on the MSDN Fora does suggest a resolution, it might work:

http://social.msdn.microsoft.com/Forums/en-US/sharepoint2010programming/thread/a09957c6-d681-40b6-aed0-483f0831af57

share|improve this answer
    
Beat me by few minutes :) –  Shoban Apr 11 '11 at 15:19
    
Wifi at BPCUK is faster than I thought ;) –  James Love Apr 11 '11 at 15:23
    
OK, but what is BihConsumerInterop? –  Dave Apr 11 '11 at 15:31
    
Something used by the SP2010 Server Search infrastructure. Not much documentation out there on it, think it's internal code. –  James Love Apr 11 '11 at 15:36
    
Is putting the DLL in the GAC as simple as copying it to the assembly folder? And, will we have to do this everytime we create a new server? –  Dave Apr 11 '11 at 18:08
show 1 more comment

I ran this through Reflector and it seems like it is dynamically loading an unmanaged DLL. The code looks for the location of the DLL to load in the Registry at HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\14.0\BIH".

I have that registry path on my server, but I found something about it relating to Analysis Services which I don't currently have configured.

share|improve this answer
add comment
  1. BihConsumerInterop not deployed to GAC
  2. BihConsumerInterop not build for "Any CPU" or "x64"
  3. Solution with BihConsumerInterop assembly not deployed at all.
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.