Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have the following issue. To make the automatization of the process I need to fix the date & time for each process step. First I used the calculated column but it didn't work. I found suggestion how to make it SharePoint Designer Workflow, set field but didn't understand how to apply it and created the question: How to fix [today] and [now] in the SharePoint 2010 list.

Using this information as well as recommended guides from answer on this question SP Designer Workflows doesn't work and this video https://www.youtube.com/watch?v=OQYldayTe1M

I created the workflow for process: I need that when a person chooses "Yes" in the Status column that in column "Date & Time" appears current date and time and that this time would not be changed if somebody updates the information in the string. enter image description here

But it doesn't work.

During the publishing the next mistake appeared

enter image description here

Additional info about mistake:

System.InvalidOperationException: Operation failed with error System.UnauthorizedAccessException: The caller does not have the necessary permissions required for this operation. Permissions granted: None. Required permissions: WriteScope. HTTP headers received from the server - ActivityId: 955a3a11-0d8c-4875-9578-e29dc77813cb. NodeId: 011D-DB3-PFE03. Scope: /SPODScope/default/53737d38-1b0c-454f-bcb8-84f703c0a710. Client ActivityId : 7763a89c-385b-1025-e86c-040129c55387. ---> System.Net.WebExcept

but than it was published.

Is the problem in the mistake or in my code?

Thank you in advance!

share|improve this question

1 Answer 1

up vote 5 down vote accepted

This is a known issue with Workflow Manager:

If the permissions of a workflow scope are set to BUILTIN\Administrators, Client Applications must run using elevated permissions

If the permissions of a workflow scope are set to BUILTIN\Administrators, which is the default setting, an exception similar to the following is thrown if the client application is not run using elevated permissions.

This is because Windows doesn’t grant the current user the Admin token unless the user is running in an elevated process, regardless of whether that user belongs to the Administrators group.

To resolve this issue, there are two choices.

  • Run the client application using elevated permissions.

  • Update the WorkflowAdminGroupName of the scope to another non-Administor group to which the user belongs, such as BUILTIN\Users. One way to do this is to run the following PowerShell script.

PowerShell Script

$sec = New-Object Microsoft.Workflow.Client.Security.WindowsSecurityConfiguration("All Users")
$sec.WorkflowAdminGroupName = "Users"
share|improve this answer
    
Thank you very much for help! –  Galina Jul 27 at 21:18

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.