Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

We are trying to configure same schema on our new SharePoint Foundation 2013 that we used on SharePoint Foundation 2010. We have a document library with folder structure like this:

| - 100_FIRST
| ---- 100_1_SUBFOLDER_OF_FIRST
| ------------100_1_1_THIRD_LEVEL_SUBFOLDER
| ------------100_1_2_NEXT_THIRD_LEVEL_SUBFOLDER
| ---- 102_OTHER_SUBFOLDER
| - 200_SECOND
| - 300_THIRD
etc...

And for example we want to grant access to specific user just into the folder 100_1_1_THIRD_LEVEL_SUBFOLDER and not in any other folders.

On previous 2010 SharePoint installation when I granted access to some subfolder to some user, on parent folders were Limited Access permissions automatically assigned to him, so he can traverse directly to the subfolder to which he has access.

On new installation SP 2013 (clean installation in new Active Directory, no migration) if I grant access to some subfolder (eg. 100_1_1_THIRD_LEVEL_SUBFOLDER) to user, he can access it via direct url link, but if he open Document Library containing this folder, he sees it as empty, because he does not has access to folder containing that granted subfolder (this is partially correct as he should not see any content of parent folder, but he should see folders in path to the subfolder he has granted access).

I am missing any settings on SP 2013 or this is not included in Foundation version of 2013?

Thanks for any advice!

share|improve this question
    
Might I suggest using extra list instead of folders. You can have all permission control, and folders are just a bad idea in SharePoint. Folders make your URLs too long and you can lose your files if you exceed 256 characters in your URL. Also, it can turn into a permissions nightmare once you start getting too many folders in the list. Plus it is harder for the search crawlers to find your stuff. Folders are so 90's man :) –  lazoDev Jul 22 at 17:53

1 Answer 1

Same issue happened to me before. So, we used Tree view, which kind of allows someone with no permissions in the Parent folder to expand and view the Sub-folders. They should expand the folder tree structure in the left pane, until the exact sub-folder they have access to is reached.

share|improve this answer
    
Yes, Treeview could be workaround for accessing via web interface, but when users maps DMS in Explorer as Network Drive they can't see the folders and then they are complaining why they can't see content :-( –  vladimirm Jul 28 at 9:59
    
You could try adding 'View Items' permission to the 'Limited Access' permission level. Go to Site settings > Site Permissions. Click 'Permissions level' button. Select 'Limited Access' and click 'Edit Permission level'. In the edit permission page, check 'View Items' under List Permissions. If the Limited Access Level is read only, copy it to a new level and add View Items. –  Veda Selvam Jul 29 at 2:46

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.