Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have created in my VS2013 solution a Masterpage module. The problem is that during feature activation I encounter a message 'Cannot create "_catalogs/masterpage', as if the feature was not being deployed to the masterpages catalog but rather SP tried to create the folder. Also in the ULS logs there is a message that the type of the module cannot be determined. Here is my elements.xml:

<?xml version="1.0" encoding="utf-8"?>
<Elements xmlns="http://schemas.microsoft.com/sharepoint/">
  <Module Name="Masterpage" Path="Masterpage" Url="_catalogs\masterpage" List="116">
    <File Url="SPTMPL.master" Type="GhostableInLibrary" IgnoreIfAlreadyExists="TRUE">
      <Property Name="Title" Value="SPTMPL"/>
      <Property Name="MasterPageDescription" Value="TMPL SharePoint MasterPage"/>
      <Property Name="UIVersion" Value="15" />
      <Property Name="ContentType" Value="$Resources:cmscore,contenttype_masterpage_name;" />
    </File>
  </Module>
</Elements>

Any ideas where the problem lies?

share|improve this question

1 Answer 1

up vote 0 down vote accepted

perhaps you have the url wrong

this

Url="_catalogs\masterpage"

should be

Url="_catalogs/masterpage"
share|improve this answer
    
<facepalm> yes, thank you very much, such a dumb mistake –  n0e Jul 21 at 10:23

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.