Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have a SharePoint server which is otherwise operating normally, but all of a sudden Visual Studio refuses to deploy SharePoint solutions. It's worked normally in the past. It is now giving an error:

Error occurred in deployment step 'Recycle IIS Application Pool': A task was canceled.

I've seen various IIS recycling errors before, but I think the unique part here is the "A task was canceled" bit.

Does anyone know what the cause might be?

share|improve this question

1 Answer 1

try to reset IIS on the server. if that fix the problem then fine Other wise reboot the all server in the farm.

check this blog for more detail: http://www.c-sharpcorner.com/UploadFile/sagarp/sharepoint-error-occurred-in-deployment-step-recycle-iis-a/

also this one: http://social.msdn.microsoft.com/Forums/en-US/3c2e214a-20b8-43ff-a52a-4ec6b8eaab51/getting-error-message-a-task-was-canceled-while-deploying-solution-in-sharepoint-2013?forum=sharepointdevelopment

share|improve this answer
    
I have tried rebooting. The "A task was canceled" part is not a very common error. I haven't found any resources on this. –  MgSam Jul 18 at 12:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.