Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

In SharePoint 2007, clicking on a PDF in a document library would open it within the browser. In SharePoint 2010, doing the same asks me to save the PDF. How can I force SharePoint 2010 to just open PDF files without making me save them?

share|improve this question
add comment

5 Answers

up vote 19 down vote accepted

Bad advice! you should not just blindly enable permissive mode.

First of all there are good reasons why SP2010 does not render files in browser, PDF inluded, pr default. The reason is client object model.

PDF allows for Javascript execution, and though to some degree the threath model is the same as with SP2007, CLient object model makes it alot easier to create potential malicious code in PDF's.

After considering the possible dangers you Could enable permissiv mode, but that works for all file types. Instead it is much less of a security hole to just enable pdf as allowed inline mime types for the web application:

$webapp = Get-SPWebApplication <your webapp url> 
$webapp.AllowedInlineDownloadedMimeTypes.Add(“application/pdf”)
$webapp.Update()

Read a thorough post of he potential dangers here.

share|improve this answer
add comment

You could set the web application browser file handling setting to strict. This means that SharePoint will tell the browser to open the file in the client application, instead of opening it in the browser itself.

Browser File Handling

share|improve this answer
add comment

This is controlled by the installation of Acrobat itself, not SharePoint. By default, PDFs open in the browser but many corporate installs force it to open in a separate window for support reasons.

Many users do not realize they are viewing a PDF instead of a web page and get confused when the normal web tools do not work properly. The bigger the corporation, the more likely this is to be the default.

share|improve this answer
    
This is correct for my situation. Our Infrastructure/Network guys control how pdfs open on all of our machines. In order to get our pdfs to open in Adobe they have to change the registry in our machines. Also we changed the SharePoint site to permissive as well. Anyway we tested all of this and it works for us. –  govgirl Feb 16 '12 at 18:22
add comment

I agree with Anders Rask that the solution provided by Wictor is not the best solution. Making it permissive at the Web Application level is the last thing to do.

If you want to set permissive, it can be done at the Site Collection, Site and List level too. This will reduce the risk to a targeted area. But note here that setting to permissive will allow other files to run in browser like flash etc.

if you just want to allow pdf, then Anders's solution is good.

For all the ways you can allow pdf to open in browser.. refer http://howtosharepoint.blogspot.com/2011/04/open-pdf-files-in-browser.html

share|improve this answer
add comment

This change was made due to security reasons in SharePoint 2010. You know that PDF actually stands for "Potentially Dangerous Files".

You can change it to a less secure mode, per Web Application, in Central Admin. Just change the Browser File Handling property to Permissive and your good to go.

share|improve this answer
5  
Ha! "Potentially Dangerous Files". I believe that... PDF is a pretty reliable delivery mechanism for exploit code these days. –  Sean Earp Apr 8 '11 at 23:26
    
Could you be more specific about how to get to those permissions, please? –  Daniel Williams Jul 9 '11 at 0:28
2  
Have to vote this one down... There are more suttle ways to enable for specific mime types only, instead of disabling security entirely. Se my answer below –  Anders Rask Jul 10 '11 at 22:18
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.