Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I'm logged in on my SharePoint 2010 server machine (running Windows Server 2008 R2) and using the "Open with Explorer" feature in a document library to copy another full directory from a separate server running as a file server into my document library. Our network is full 1Gbps and these two machines are sitting right next to one another separated by less than ten feet of Cat-6 cable, yet my transfer speed starts below 100kbps and slowly degrades over time. How do I fix this?

share|improve this question
    
Thanks to Johnny P - I've been wondering about this for years and was skeptical at your fix but it worked like a champ! Thanks for ending years of misery. –  user10082 Aug 14 '12 at 19:28

3 Answers 3

up vote 18 down vote accepted

Using the steps from this source will restore full connection speed.

  1. In Internet Explorer, open the Tools menu, then click Internet Options.
  2. Select the Connections tab.
  3. Click the LAN Settings button.
  4. Uncheck the “Automatically detect settings” box.
  5. Click OK until you’re out of dialog hell.

This will need to be done on every machine that makes use of the "Open with Explorer" feature.

share|improve this answer
    
It seems, but it worked. Thanks a lot! –  Drake Nov 5 '12 at 15:36
    
I would also just like to thanks Jonny for his simple answer. I was a little skeptical at first but it does seem to have fixed the issue. Would anyone know why this actually fixes the problem though as it will be quite a hassle to have to advise all my users to make this change on their IE. –  user14449 Jan 27 '13 at 22:28
    
This solution works great and solve issues with very slow files transfer but I noticed that in some of my users checkbox “Automatically detect settings” after some time automatically returned to be check? Does anybody had the same story and found solution? I will be very grateful for any advice. –  Andrzej Mar 6 '13 at 9:24
    
I've noticed that tickbox cause performance issues with other applications before as well - clearly in the case of WebDAV operations Windows tries too aggresively to find proxy servers and other network helpers - as that's what that tickbox does. Very strange. –  Ashley Steel May 7 '13 at 15:27

Unchecking the "Automatically detect settings" box worked perfectly for me. I had a transfer that was stating it would take 14 hours and as soon as I unchecked the option it changed to 6 hours and then subsequently finished in a matter of seconds.

Great work JonnyP

share|improve this answer

Are you certain that your hardware is up to speed for 2010? Can you check the CPU and Memory usage on both the web front end and the database server? Is a crawl running for search?

Also, if you are using Sql Express for your database, check to see how much RAM is being used as it is limited to 1GB that it will use. If you are at that limit then your DB is swapping to disk which would explain the performance degradation.

share|improve this answer
1  
The box that's running SharePoint 2010 is a Windows Server 2008 R2 virtual machine with three CPUs and 18GB of RAM. SQL Server 2008 is installed. I asked this question with the express purpose of answering it myself, as I found my own solution days ago and wanted to add the question/solution to this site so others might benefit from it. –  newuser Apr 8 '11 at 21:14

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.