Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

When users open files to edit them on my SharePoint 2010 install I would like to force the dialog box that opens to uncheck the "Use my local drafts folder" box by default and prevent the user from changing this. Can it be done? How?

Alternatively that dialog box can be eliminated altogether as long as I can set every user to never use their local drafts folder by default.

Edit: I should have specified this earlier, but I would like to force this change across the entire network through AD or group policy or from the back-end of SharePoint itself. I am aware that I can use Word or Excel to change the default for any Office file, but I would like to take the option away from my users altogether for all files.

Edit 2: We're currently using Office 2007 with no immediate plans to move to 2010.

share|improve this question

3 Answers 3

up vote 5 down vote accepted

Office 2010:

This can be set using group policy templates:

  • Category: Microsoft Office Document Cache
  • Policy: Check-out to local disk
  • Associated Registry Key: software\policies\microsoft\office\common\offline\options
  • Registry Value Name: UseLocalDrafts
  • Registry Value: 0

Office 2007:

Set the following entry in the registry using group policy:

  • Key: HKEY_CURRENT_USER\Software\Microsoft\Office\Common\Offline\Options
  • Registry Value Name: Local
  • Registry Value: 0 (DWORD)
share|improve this answer
    
I can't remember if this feature existed for Office 2007 but if it did, you should find it at the same place in those administrative templates. –  Alex Angas Apr 15 '11 at 3:39
    
We are still using Office 2007 in my office, so I'll have to see if this method still works for us. I'll be sure to check back and let you know! :) –  newuser Apr 18 '11 at 13:28
    
We can't find anything in GP for Office 2007 that matches what you're referencing in your answer. :( –  newuser Apr 21 '11 at 20:18
    
@JonnyP: I've updated the answer with a registry setting that should fix the issue for you. –  Alex Angas Apr 22 '11 at 8:52
    
Great, we'll try this out next week and I'll let you know. :-) –  newuser Apr 22 '11 at 13:46

You can set the "Use my local drafts folder" option to be unchecked by default:

  1. Open Office Word.
  2. Click on the Office button.
  3. Click on 'Word Options'.
  4. Click on 'Save' in the left menu.
  5. Under the 'Offline editing options...' section select 'The web server' instead of 'The server drafts location on this computer'.
  6. Click 'OK' twice.
share|improve this answer
    
Hey, thanks for your response. I've edited my question to better reflect what I want since I wasn't very clear originally. –  newuser Apr 8 '11 at 17:39

To save others the effort, here is the contents for a .reg file, just copy and paste:

Windows Registry Editor Version 5.00

; Make 'Use my local drafts folder' un-ticked by
; default when checking out a document from sharepoint.

; Microsoft Office 2010+
[HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\Common\Offline\Options]
"UseLocalDrafts"=dword:00000000

; Microsoft Office 2007
[HKEY_CURRENT_USER\Software\Microsoft\Office\Common\Offline\Options]
"Local"=dword:00000000
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.