Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have a basic WSS 3.0 site set up with an ASP.NET membership database and default forms login. There is no custom code or any customization on the entire site.

When I try to log in, I get 'unknown error', regardless of whether username/pass is correct or not. An iisreset fixes this for the rest of the day. When I check the site again in the morning, same unknown error.

Only error in /12/logs:

01/11/2010 12:00:39.11 w3wp.exe (0x02FC)
0x0D58 Windows SharePoint Services
General
8dzz High Exception Type: System.ArgumentNullException Exception Message: Value cannot be null. Parameter name: value

EDIT: Here's my membership/role providers in web.config:

  <membership defaultProvider="FormsMember">
    <providers>
      <add
        connectionStringName="ConnectionString"
        enablePasswordRetrieval="false"
        enablePasswordReset="true"
        requiresQuestionAndAnswer="false"
        applicationName="/"
        requiresUniqueEmail="false"
        passwordFormat="Hashed"
        maxInvalidPasswordAttempts="5"
        minRequiredPasswordLength="1"
        minRequiredNonalphanumericCharacters="0"
        passwordAttemptWindow="10"
        passwordStrengthRegularExpression=""
        name="FormsMember"
        type="System.Web.Security.SqlMembershipProvider,System.Web,Version=2.0.0.0,Culture=neutral,PublicKeyToken=b03f5f7f11d50a3a" />
    </providers>
  </membership>

  <!-- role provider -->
  <roleManager enabled="true" defaultProvider="FBARole">
    <providers>
      <add
        connectionStringName="ConnectionString"
        applicationName="/"
        name="FBARole"
        type="System.Web.Security.SqlRoleProvider,System.Web,Version=2.0.0.0,Culture=neutral,PublicKeyToken=b03f5f7f11d50a3a" />
    </providers>
  </roleManager>

EDIT 2:

After making the suggested changes to web.config to view the error, here's what the site now says once the login fails:

Value cannot be null. Parameter name: value at System.String.EndsWith(String value, StringComparison comparisonType)
at Microsoft.SharePoint.ApplicationRuntime.SPRequestModule.PostAuthenticateRequestHandler(Object oSender, EventArgs ea) at System.Web.HttpApplication.SyncEventExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)

EDIT 3:

I am still having this issue.

share|improve this question

4 Answers 4

How have the FB settings been applied via a SPWebConfigModification object? Just wondering if the farm is updating your web config settings which is messing things up.

share|improve this answer
    
i have done nothing with this –  Anonymous Jan 12 '10 at 14:07
    
@Simon: The 'add comment' feature on the question is the best place to ask for more information. Otherwise the question gets cluttered with answers that aren't really answers. Thanks! –  Alex Angas Jan 13 '10 at 1:01
    
@Alex - sure - cheers for feedback. –  Anonymous Jan 15 '10 at 7:47

Find and set CallStack="true", CustomErrors="Off," debug="true" in web.config (You will probably have to edit the web.config that is in your LAYOUTS folder, since that is where I expect your logon page to reside) so that - instead of getting unkown error - you will hopefully get a more meaningful error + stacktrace. The stacktrace is what we are after. Please post it here.

share|improve this answer
    
thanks, i made these changes. unfortunately, we will have to wait until tomorrow since changing web.config does an automatic IISreset which solves the problem for a day –  Anonymous Jan 12 '10 at 14:05
    
It actually performs an application pool recycle, which is similar to an iisreset, but not quite the same. Looking forward to tomorrow :D –  Jaap Vossers Jan 12 '10 at 14:24
    
hi, i have posted the new error –  Anonymous Jan 14 '10 at 17:30

what exactly do you mean with "default forms login". What role provider and/or membership provider are you using?

When debugging this issue also check event for errors after doing a login.

If your FBA is using SQL server, also check the SQL logs.

Also i can warmly recommend using SQL Profiler to see whats actually fetched from SQL server when doing a login.

hth Anders Rask

share|improve this answer

Is there some kind of job that runs overnight, or is the web app set to recycle once per day?

share|improve this answer
    
yeah, app pool recycles every night, but that's default for all .. –  Anonymous Jan 11 '10 at 17:49
    
no job running at night. this site is as OOB as it gets –  Anonymous Jan 11 '10 at 17:50
    
@next_connect: Could you please make this a comment as it isn't an answer, rather a request for more information. Thanks! :) –  Alex Angas Jan 11 '10 at 23:03

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.