Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

We have a problem with opening Office documents where some users get a login dialog and others don't. If the user press Cancel the dialog disappears and the document is opened properly. If the enter their credentials they are usually prompted the same dialog again (until they press Cancel).

All computers have the site in their Intranet-zone and they all have IE8. I believe the error is related to settings (registry?) on the computers as the same user can use another one without getting the dialog. The error exists mainly on machines running Windows 7. At least one tested on Windows 7 where it didn't work and then in Vista where it worked as expected (no dialog).

I have found a kb-article which I think can be related (http://support.microsoft.com/?id=943280) but as far as I understand I should have the error in Vista as well. I have been unable to test the solution (editing the registry).

Any suggestions?

Regards, Adrian.

share|improve this question
add comment

2 Answers 2

Do you have Kernel Mode Authentication enabled on your IIS site for your SharePoint web application? This is normally off for SharePoint sites but can be on as a result of an upgrade for example.

Useful link on this problem:

http://lambertqin.wordpress.com/2010/04/19/prompt-authentication-dialogue-issue-using-ie8-to-access-sharepoint-sites-hosted-on-windows-server-2008r2/

You can also continue to use Kernel Mode Authentication on the 2007 version of SharePoint by configuring it to use the application pool credentials. The suggested approach is to use the useAppPoolCredentials attribute of the windowsAuthentication element in the applicationHost.config file.

More details on Spence Harbar's site. Remember that this fix won't work on SharePoint 2010 (it uses a newer authentication protocol), only 2007. On SharePoint 2010 you will still need to disable KMA for your content web applications.

share|improve this answer
    
We do indeed! I will try to get it unchecked and come back with the results. Forgot to mention that the site is MOSS 2007. –  Adrian Apr 3 '11 at 20:39
    
To clarify, Kernel Mode Authentication is disabled by default for web apps created in SharePoint 2010. This wasn't the case for SharePoint 2007. –  SPDoctor Apr 4 '11 at 8:45
    
And unfortunately, disabling it made the site inaccessible –  Adrian Apr 7 '11 at 8:49
    
Should still work but may need work on configuration. A better fix is to configure KMA to use the app pool credentials - I will update answer with more details. –  SPDoctor Apr 7 '11 at 9:19
add comment

I think this issue might have something to do with WebDAV protocol for opening office documents. Here the relevant knowledge-base article:

SharePoint 2007 or 2010: Office Documents open ReadOnly from SharePoint site

IE8 will try a few different methods to open the documents and the WebDAV method has issues with Windows 7.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.