Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have a clean installation of Sharepoint 2010 running in a Win 7 machine and I can't create Web Applications because the New button in the ribbon is disabled.

The user account I'm logged in is a local server admin and a farm admin. The site is in the Trusted Sites zone.

I googled it and the main suggestion seems to be running IE in Admin mode. I did this, didn't work. I also ran the Configuration Wizard, also no result.

Anybody has any idea why I have the button disabled?

Thank you in advance

share|improve this question
    
Thanks a lot. I am struggling with this from many days. your article help me to come out from this problem. :) –  user8904 Jun 17 '12 at 3:31

9 Answers 9

You could try to create a new web app via powershell. It will fail, but you might get an error message that points you to the problem.

share|improve this answer

Have seen this problem before.

There is a "Administrator" account on Win7 which is disabled by default. Log into Central Admin using that account. Start -> Run -> compmgmt.msc select "Local Users and Groups" and enable "Adminstrator" account and set a password.

Now login to Central Admin using this account.

share|improve this answer

I experienced the same issue (using Server 2008 R2). For some reason User Account Control (UAC) prevents a new web application from being created.

Go into "Control Panel" and switch "View By" to "Small Icons". Click on "User Accounts" and then click on "Change User Account Control Settings". Drag the slider down to "Never Notify".

Reboot the system. Nothing will change until the machine is restarted.

Open up IE as administrator and navigate to your central admin page. Now navigate to "Manage Web Applications" and the "New" option will appear.

share|improve this answer

Try AlexPoint his suggestion and monitor the ULS and the eventvwr logs.

Don't know if the account you use is the installation admin service account, if it isn't try logging on with that account and see if the option is there.

Keep us posted.

share|improve this answer

I have seen that behavior before (the new web app button was grayed out). When I have seen that, I go to the Security section of Central Admin to confirm the account was in Farm Admins and then go back to the Manage Web Applications area and the New button has been (mysteriously) activated and is usable.

It is possible you just restarted the machine? I haven't tested this theory, but I seem to see that after restarting a Virtual Machine, and I wonder if SharePoint was still starting things up or if some required process was not ready to allow the creation of a new web app, and, in the time it took me to go look at the Farm Admins page and return, it became ready.

share|improve this answer

Run your browser in elevated mode and the problem is resolved.

share|improve this answer

Run the link of Central Administration as administrator.

This helps getting you correct permissions in Central Administration

share|improve this answer

All good suggestions - it can actually be a combination of a few..

1) Account you need to use is the Farm Account (must be a member of the SharePoint Farm Administrators Group added through Central Administration)

2) Farm account MUST be a member of the Local Users and Groups Administrators group

3) Must right click on the Central Administration icon and select "Run as administrator"

RECOMMENDATION TO ALL: Don't follow Microsoft's instructions to use an installation account - that is simply stupid. When you use a specific account for installation, services, etc. are assigned to it. If you want to then create a farm account, you'll waste much valuable time resetting service ID's, assigning to proper security groups, etc. Install using the Farm account (once assigned to the Local Users & Groups Administrators group). The same goes for using a SQL Server account - if you use an installation account (ala 2008) or accept the default accounts (ala 2012), same issue. Install using the account that will be running the services!

share|improve this answer

Believe it or not, I could actually solve this issue by adding the central admin to the list of safe local intranet sites in IE (please note that it didn't work for trusted sites, just intranet sites).

I followed the steps in this tutorial (after trying many, many things) and it solved my issue: http://epmgelist.wordpress.com/2013/06/14/central-administration-greyed-out-ribbons-and-missing-functions/

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.