Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have library configured to receive attachments. I configured the SMTP and SharePoint to receive e-mail, in my old scenery SharePoint 2010 this worked, but in migrated SharePoint 2013 don't work. The e-mail stop in "drop" folder.

Can anyone help me?

share|improve this question
    
Tested with all the answers, but nothing solved my problem. –  Diego Hillesheim Jul 14 at 17:13
    
Can you give us more details about your environment? I read one app server... but is there more? 2 WFE, distributed cache server, search servers, ... –  Marco Scheel Jul 15 at 8:29
    
Try this powershell Get-SPServiceInstance | ? {$_.Typename -eq "Microsoft SharePoint Foundation Incoming E-Mail"} What is the result? –  Marco Scheel Jul 15 at 8:30
    
return the name, status and guid. Thes status is "Online" –  Diego Hillesheim Jul 15 at 12:06

4 Answers 4

Couple of things to check:

  • Make sure "Microsoft SharePoint Foundation Incoming E-Mail" timer job is running on the server where SMTP confgiured.
  • From Central admin, Incoming email setting > advance setting, make sure drop folder path added here.
  • Make sure Timer Services having the correct permission on drop folder.
share|improve this answer
    
I go check this. –  Diego Hillesheim Jul 1 at 11:20
    
I checked the second and third. I can't found timer job, how I do this? –  Diego Hillesheim Jul 1 at 12:04
    
I found! All is ok. Any other idea? –  Diego Hillesheim Jul 1 at 12:13

If you have more than one APP Server, check whether the drop folder is on the same server where the timer is running, else you have to share the folder and add the path in Central Admin.

Reference : http://bernado-nguyen-hoan.com/2013/06/18/solving-sharepoint-2013-incoming-mails-stuck-in-drop-folder/

share|improve this answer
    
I have one App Server. –  Diego Hillesheim Jul 9 at 14:07
    
I think it should be issue with permissions on the folder. Have you tried to give read permission to Timer Service Account. Try changing Service accounts if one doesn't work for some reason. –  Sudhakar Jul 9 at 14:09
    
Yeah, give 'Everyone' Full control on the drop folder to see if that is the issue. Then scale back –  Colbs Jul 10 at 21:17

If nothing above has helped, then I would check whether your application pool and timer service accounts have permissions to the drop folder. Probably they don't. Some time ago it was the cause of the issue in my case.

To configure this permissions do the following:

  • Verify that you have the following administrative credentials: You must be a member of the Administrators group on the computer that contains the e-mail drop folder.

  • In Windows Explorer, right-click the drop folder, click Properties, and then click the Security tab.

  • On the Security tab, under the Group or user names box, click the Edit button.

  • In the Permissions for Windows Explorer dialog box, click the Add button.
  • In the Select Users, Computers, or Groups dialog box, in the Enter the object names to select box, type the name of the timer service or application pool identity account for the Web application, and then click OK.
  • In the Permissions for User or Group box, next to Modify, select Allow. Click OK.

If it doesn't help, try to follow this article: Configure incoming e-mail (SharePoint Foundation 2010)

share|improve this answer
    
Had already occurred and not solved. –  Diego Hillesheim Jul 9 at 14:08
    
Then I would try to follow the article from the start for another library. Probably, at first there were issues with permissions while creating contact in AD for the lib and after fixing it, some inconsistency remains and it doesn't work. If you follow the article for another lib you can exclude this potential issue. –  MikhailSP Jul 14 at 8:18
    
Of course, you can skip the part regarding setting up SMTP server as it seems it works well. –  MikhailSP Jul 14 at 8:23
up vote 0 down vote accepted

As I was taking too long to resolve this error, I created another SharePoint farm and the error did not persist. It seems that the machine name (vfesharepoint2013) was very large and we think the netBios was lost because of this.

Thanks fo all.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.