Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I'm working with SharePoint 2010 Enterprise and we are using Search Server 2010 with the publishing workflow and a Forms Based Authentication on our main Web App, our Web Application is extended to a port 81 that allows NTLM for the search account. The problem we encounter is getting content crawled in the sites, the search account is set up with read only rights and access to the content. All sites and Libraries and Lists are set to allow Searching and Indexing and we don't get errors in crawling URL's, they just never happen.

We have a Home top level with an About, Public, Communities and Projects all as subsites of Home, yet when I run a crawl on the site I am only getting the main page and About. The Public, Communities and Projects do have the Publishing Worklfow (major/minor) versions on the content, although I am not sure this is an issue. In some tests I seem to be able to get more content using the main site (almost all), using the extended site I don't get much.

Not sure if anyone uses the publishing workflow but if you do how are you crawling and have you encountered issues? Any recommendations on setting up Content Site URL's and settings to get search results? Anything that works?

Thanks!

share|improve this question
add comment

1 Answer

up vote 3 down vote accepted

The Search account will only index published content, so that might be your issue. Try logging in as your default content account (the one that indexes the pages) to see what it looks like from that users perspective.

The best way to add reader rights for the default content access account is from inside Central Administration under web applications. Select the relevant web app and add a Read policy.

Also double check the crawl log from inside CA > Service Applications > Search Service to make sure there are no crawl errors.

Related tip: setting a NOINDEX css class on the divs that make up your navigation and similar will remove noise from your indexes (else a search for "Projects" will return all pages since they all have Projects in their top navigation

share|improve this answer
    
You hit on the issue, I had logged in originally when I set this up and when I was getting problems but we had some configuration changes going on behind the scenes since then. Logging in recently showed we had more issues and it turned out that the configuration files lost more safe control options and logging in on those sites was no longer working. With a long standing issue never expect things haven't changed along the way. –  MichaelF Mar 27 '11 at 19:39
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.