Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

Running on SharePoint 2010 Foundation. I have created a custom master page which works well for the most part. In SharePoint Designer, I've set the master page as default & custom master pages. When I go to Site Settings, however, the site reverts back to the original master page. When I go to list settings it just displays an error. I don't know if the error is related, but I want to fix the master page issue first. How can I get my master page to be the same across my entire site?

I've created other customer master pages for other site collections on this same server, and they are working fine. Just this one acting up.

Thanks!

share|improve this question

closed as too localized by SPDoctor, Alex Angas Aug 6 '11 at 9:57

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

1 Answer 1

up vote 1 down vote accepted

Yup, I removed the since I didn't need it. It appears these app pages need it. Threw it back in and all pages are now using my master page AND the error is gone.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.