Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I get this nasty exception in one of my SharePoint servers (version 2010).

SharePoint error 0x81020026, "The page you selected contains a list that does not exist. It may have been deleted by another user."

The SharePoint server has been setup by using it's netbios name - "customer-intranet" and the error only occurs when we are trying to upload upload a document or create a new list item using it's FQDN or IP (intranet.customer.com, 192,168.11.11). And everything works fine when we access the server with it's netbios name so the lists are there and they do work just fine!

Any advices?

Thanks :)

share|improve this question

1 Answer 1

up vote 2 down vote accepted

Are the two names representative of two different zones, i.e. NetBios name when accessed locally but then the FQDN when accessed elsewhere?

It sounds like this is an issue with the Alternate Access Mappings for that server in Central Administration. If they are in the same zone, add the FQDN as an internal URL for the zone that the NetBios name is used for. If they are different zones, then the FQDN should be defined for that zone, most likely as the default.

Once the Alternate Access Mappings are in place, both URLs should work equally.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.